0.8.8 installer does not install required dependencies

Hi there,
I just spun up a Linode to put OSP on, and running the installer on a fresh Debian 10 install I discovered that it does not install MariaDB (MySQL). I spent a couple hours trying to debug it and then eventually found some logs indicating that no connection to the SQL server could be made.

I was able to reproduce this issue on a non-Linode install as well on Debian 10.

This results in an NGINX 500 page when trying to load the interface after a fresh install.

Yeah, Iā€™m aware that debian does not contain the mysql-server package. You can install the mariadb package and then do an install and it should work

1 Like